CVE-2011-3170

Priority
Medium
Description
The gif_read_lzw function in filter/image-gif.c in CUPS 1.4.8 and earlier
does not properly handle the first code word in an LZW stream, which allows
remote attackers to trigger a heap-based buffer overflow, and possibly
execute arbitrary code, via a crafted stream, a different vulnerability
than CVE-2011-2896.
References
Bugs
Notes
 mdeslaur> This also affects cups 1.5.x and isn't fixed in 1.5.0
 mdeslaur> gimp was fixed correctly with a single commit, so doesn't have
 mdeslaur> this issue, which is an incomplete fix.
Assigned-to
mdeslaur
Package
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):DNE
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 17.04 (Zesty Zapus):DNE
Package
Source: cups (LP Ubuntu Debian)
Upstream:released (1.5.0-8)
Ubuntu 17.10 (Artful Aardvark):not-affected (1.5.0-8)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was not-affected [1.5.0-8])
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (1.5.0-8)
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1.5.0-8)
Ubuntu 17.04 (Zesty Zapus):not-affected (1.5.0-8)
Patches:
Upstream:http://cups.org/str.php?L3914
Upstream:r9865
Package
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 17.04 (Zesty Zapus):needed
Patches:
Upstream:http://www.swi-prolog.org/git/packages/xpce.git/commit/30fbc4e030cbef5871e1b96c31458116ce3e2ee8
Package
Source: gimp (LP Ubuntu Debian)
Upstream:not-affected
Ubuntu 17.10 (Artful Aardvark):not-affected
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was not-affected)
Ubuntu 14.04 LTS (Trusty Tahr):not-affected
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected
Ubuntu 17.04 (Zesty Zapus):not-affected
More Information

Updated: 2017-08-11 23:14:27 UTC (commit 13081)