CVE-2011-3131

Priority
Description
Xen 4.1.1 and earlier allows local guest OS kernels with control of a
PCI[E] device to cause a denial of service (CPU consumption and host hang)
via many crafted DMA requests that are denied by the IOMMU, which triggers
a livelock.
Assigned-to
mdeslaur
Notes
mdeslaurThis is XSA-5
Package
Source: xen (LP Ubuntu Debian)
Upstream:needs-triage
Patches:
Upstream:http://xenbits.xen.org/hg/xen-unstable.hg/rev/537ed3b74b3f (unstable)
Upstream:http://xenbits.xen.org/hg/xen-4.1-testing.hg/rev/84e3706df07a (4.1 testing)
Upstream:http://xenbits.xen.org/hg/xen-4.0-testing.hg/rev/789ff1a462b8 (4.0 testing)
Binaries built from this source package are in universe and so are supported by the community. For more details see https://wiki.ubuntu.com/SecurityTeam/FAQ#Official_Support
Package
Upstream:needs-triage
Binaries built from this source package are in universe and so are supported by the community. For more details see https://wiki.ubuntu.com/SecurityTeam/FAQ#Official_Support
Package
Upstream:needs-triage
Binaries built from this source package are in universe and so are supported by the community. For more details see https://wiki.ubuntu.com/SecurityTeam/FAQ#Official_Support
Package
Upstream:needs-triage
Binaries built from this source package are in universe and so are supported by the community. For more details see https://wiki.ubuntu.com/SecurityTeam/FAQ#Official_Support
More Information

Updated: 2020-01-29 19:42:11 UTC (commit 768ceb2fdee6790d707d0f681e1b54916744af1e)