CVE-2011-2767

Priority
Description
mod_perl 2.0 through 2.0.10 allows attackers to execute arbitrary Perl code
by placing it in a user-owned .htaccess file, because (contrary to the
documentation) there is no configuration option that permits Perl code for
the administrator's control of HTTP request processing without also
permitting unprivileged users to run Perl code in the context of the user
account that runs Apache HTTP Server processes.
Assigned-to
mdeslaur
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):released (2.0.5-5ubuntu1.1)
Ubuntu 14.04 LTS (Trusty Tahr):released (2.0.8+httpd24-r1449661-6ubuntu2.1)
Ubuntu 16.04 LTS (Xenial Xerus):released (2.0.9-4ubuntu1.2)
Ubuntu 18.04 LTS (Bionic Beaver):released (2.0.10-2ubuntu3.18.04.1)
Ubuntu 18.10 (Cosmic Cuttlefish):released (2.0.10-2ubuntu3.18.10.1)
Ubuntu 19.04 (Disco Dingo):released (2.0.10-2ubuntu5)
Patches:
Vendor:https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=644169#19
More Information

Updated: 2019-03-19 11:59:17 UTC (commit 15472795df7e9de45b82f2d36b8b419b939f97b2)