CVE-2011-2697

Priority
Description
foomatic-rip-hplip in HP Linux Imaging and Printing (HPLIP) 3.11.5 allows
remote attackers to execute arbitrary code via a crafted
*FoomaticRIPCommandLine field in a .ppd file.
Assigned-to
mdeslaur
Notes
mdeslaurwe don't ship this script in our hplip packages. hplip is built
with --disable-foomatic-rip-hplip-install.
hardy's foomatic-filters package does have this script though.
Package
Upstream:needs-triage
Patches:
Upstream:http://bzr.linuxfoundation.org/loggerhead/openprinting/foomatic-3.0/foomatic-filters/revision/140
This vulnerability is mitigated in part by an AppArmor profile. For more details see https://wiki.ubuntu.com/Security/Features#apparmor
Package
Source: hplip (LP Ubuntu Debian)
Upstream:needs-triage
More Information

Updated: 2019-12-05 20:57:25 UTC (commit 0aa5e7c87c8b55d2ec5c7f4ca1179cf75de91961)