CVE-2011-1169 (retired)

Priority
Description
Array index error in the asihpi_hpi_ioctl function in
sound/pci/asihpi/hpioctl.c in the AudioScience HPI driver in the Linux
kernel before 2.6.38.1 might allow local users to cause a denial of service
(memory corruption) or possibly gain privileges via a crafted adapter index
value that triggers access to an invalid kernel pointer.
Ubuntu-Description
Dan Rosenberg discovered that some ALSA drivers did not correctly check the
adapter index during ioctl calls. If this driver was loaded, a local
attacker could make a specially crafted ioctl call to gain root privileges.
Package
Upstream:released (2.6.39~rc1)
Package
Upstream:released (2.6.39~rc1)
Package
Upstream:released (2.6.39~rc1)
Package
Upstream:released (2.6.39~rc1)
Package
Upstream:released (2.6.39~rc1)
Package
Upstream:released (2.6.39~rc1)
Package
Upstream:released (2.6.39~rc1)
More Information

Updated: 2019-03-26 11:55:48 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)