CVE-2009-4032

Priority
Description
Multiple cross-site scripting (XSS) vulnerabilities in Cacti 0.8.7e allow
remote attackers to inject arbitrary web script or HTML via vectors related
to (1) graph.php, (2) include/top_graph_header.php, (3) lib/html_form.php,
and (4) lib/timespan_settings.php, as demonstrated by the (a) graph_end or
(b) graph_start parameters to graph.php; (c) the date1 parameter in a tree
action to graph_view.php; and the (d) page_refresh and (e)
default_dual_pane_width parameters to graph_settings.php.
Notes
jdstrandcross_site_fix.patch still not applied as of 0.8.7e-4
mdeslaurpatch is in fact in the lucid package
More Information

Updated: 2019-12-05 20:54:00 UTC (commit 0aa5e7c87c8b55d2ec5c7f4ca1179cf75de91961)