CVE-2009-0147

Priority
Description
Multiple integer overflows in the JBIG2 decoder in Xpdf 3.02pl2 and
earlier, CUPS 1.3.9 and earlier, and other products allow remote attackers
to cause a denial of service (crash) via a crafted PDF file, related to (1)
JBIG2Stream::readSymbolDictSeg, (2) JBIG2Stream::readSymbolDictSeg, and (3)
JBIG2Stream::readGenericBitmap.
Assigned-to
mdeslaur
Notes
jdstrandCUPS on Ubuntu uses system pdftops (compiled with --disable-pdftops)
sbeattieipe uses pdflatex from tetex-bin | texlive-latex-base
Package
Source: cups (LP Ubuntu Debian)
Priority: Negligible
Upstream:released (1.3.10)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was not-affected [1.4.1-5ubuntu2])
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1.4.1-5ubuntu2)
Package
Priority: Negligible
Upstream:released (1.3.10)
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:not-affected (linked to poppler)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was not-affected [linked to poppler])
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (linked to poppler)
Package
Source: gpdf (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Source: ipe (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was not-affected [uses system pdflatex])
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (uses system pdflatex)
Package
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Priority: Low
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was not-affected [code not present])
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (code not present)
Package
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was released [0.10.5-1ubuntu2])
Ubuntu 16.04 LTS (Xenial Xerus):released (0.10.5-1ubuntu2)
Package
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was not-affected [linked to poppler])
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (linked to poppler)
Package
Source: xpdf (LP Ubuntu Debian)
Upstream:released (3.02-2)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was not-affected [3.02-2])
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (3.02-2)
More Information

Updated: 2020-09-10 01:06:06 UTC (commit 81a23a978c4436cd99e1d040e9e73e9146876281)