CVE-2009-0146 (retired)

Priority
Description
Multiple buffer overflows in the JBIG2 decoder in Xpdf 3.02pl2 and earlier,
CUPS 1.3.9 and earlier, and other products allow remote attackers to cause
a denial of service (crash) via a crafted PDF file, related to (1)
JBIG2SymbolDict::setBitmap and (2) JBIG2Stream::readSymbolDictSeg.
Notes
 jdstrand> CUPS on Ubuntu uses system pdftops (compiled with --disable-pdftops)
 sbeattie> ipe uses pdflatex from tetex-bin | texlive-latex-base
 sbeattie> libextractor: all references to JBIG2 are commented out
Assigned-to
mdeslaur
Package
Source: cups (LP Ubuntu Debian)
Priority: Negligible
Upstream:released (1.3.10)
Ubuntu 14.04 LTS (Trusty Tahr):not-affected
Ubuntu 16.04 LTS (Xenial Xerus):not-affected
Package
Priority: Negligible
Upstream:released (1.3.10)
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:not-affected (linked to poppler)
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (linked to poppler)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (linked to poppler)
Package
Source: gpdf (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Source: ipe (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (uses system pdflatex)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (uses system pdflatex)
Package
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Priority: Low
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (code not present)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (code not present)
Package
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):released (0.10.5-1ubuntu2)
Ubuntu 16.04 LTS (Xenial Xerus):released (0.10.5-1ubuntu2)
Package
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (linked to poppler)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (linked to poppler)
Package
Source: xpdf (LP Ubuntu Debian)
Upstream:released (3.02-2)
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (3.02-2)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (3.02-2)
More Information

Updated: 2019-03-26 11:46:54 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)