CVE-2008-3443 (retired)

Priority
Description
The regular expression engine (regex.c) in Ruby 1.8.5 and earlier, 1.8.6
through 1.8.6-p286, 1.8.7 through 1.8.7-p71, and 1.9 through r18423 allows
remote attackers to cause a denial of service (infinite loop and crash) via
multiple long requests to a Ruby socket, related to memory allocation
failure, and as demonstrated against Webrick.
Notes
jdstrandthis should be fixed in svn r20243 for ruby1.9
Package
Upstream:released (1.8.7.72-1)
More Information

Updated: 2019-10-09 07:11:42 UTC (commit 33aea848a182c0afcd0a3f927a01a7ecd9a061ee)