CVE-2007-5268 (retired)

Priority
Description
pngrtran.c in libpng before 1.0.29 and 1.2.x before 1.2.21 use (1) logical
instead of bitwise operations and (2) incorrect comparisons, which might
allow remote attackers to cause a denial of service (crash) via a crafted
PNG image.
Assigned-to
jdstrand
Notes
jdstrandgiven medium because of wide install base
bug (1) is said to have been introduced in 1.2.19. Looking at
pngrtran.c in 1.2.8 and 1.2.15 (as included in Ubuntu), the vulnerable code
is not present
bug (2) still applies to 1.2.15, but not 1.2.8
reducing to negligible as pngset.c change should not do anything
Package
Upstream:released (1.0.29 and 1.2.21)
More Information

Updated: 2019-10-09 07:08:32 UTC (commit 33aea848a182c0afcd0a3f927a01a7ecd9a061ee)