Changelogs from build 20140110 to 20140110.1


  apport (2.13.1-0ubuntu1) trusty; urgency=medium
 .
   * New upstream release:
     - Fix report.test_get_timestamp test for running in other time zones.
     - Fix erroneous "gdb-multiarch not installed" warnings in ui tests.
     - Fix ui.test_run_crash_older_session test for running as root.
     - Fix ui.test_run_crash_older_session for different file system file
       orders.

 apport (2.13-0ubuntu1) trusty; urgency=medium
 .
   * New upstream release. Changes since our previous merge:
     - Do not report keys starting with '_' to the crash database. This can be
       used for keeping private keys in .crash files between crash and report
       time, or to store data between hooks etc., without cluttering reports.
     - UI: In "run all pending crashes" mode, skip reports that happened during
       logout in a desktop (specifically, logind) session; they are
       uninteresting and confusing to see at the next login. (LP: #1033932)
       They can still be reported manually with running the .crash file
       directly, but this sufficiently reduces the need to explicitly flag
       whether the report concerns a logout crash. (LP: #1067646)
     - Add support for PID namespaces (Linux containers): Crashes originating
       from a container on a system running a >= 3.12 kernel will be
       automatically redirected to apport inside the container, or ignored if
       apport is not installed in the container. Thanks to St├ęphane Graber!
     - Print a warning when trying to retrace a report from a foreign
       architecture and gdb-multiarch is not installed. (LP: #1239395)
     - etc/init.d/apport: Don't change core_pattern when running in a
       container, as this influences the host and other containers, too.
   * apport/ui.py: Rename "MarkForUpload" whoopsie hack field to
     "_MarkForUpload" and remove delta from launchpad.py. Fields starting with
     '_' are now considered private.
   * debian/apport.upstart: Add "%P" macro to core_pattern, to enable Linux
     container handling with upstart.
   * debian/apport.upstart: Don't change core_pattern when running in a
     container, as this influences the host and other containers, too.
     (LP: #1267728)


  autopilot (1.4+14.04.20131125-0ubuntu4) trusty; urgency=medium
 .
   * Seed python3-autopilots on ubuntu touch by default.


  bridge-utils (1.5-6ubuntu2) trusty; urgency=medium
 .
   * Use dh_strip rather than "install -s", since it supports cross-building.


 cups

  Changesfile not available.

  fonts-dejavu (2.34-1ubuntu1) trusty; urgency=low
 .
   * Merge with Debian, remaining changes:
     - Add 01_missing_uighur.patch: Add missing glyphs for Uighur language.
 .
 fonts-dejavu (2.34-1) unstable; urgency=low
 .
   [ Fabian Greffrath ]
   * Team upload.
   * Imported Upstream version 2.34


  gst-plugins-bad1.0 (1.2.2-1ubuntu1) trusty; urgency=low
 .
   * Merge from Debian unstable.  Remaining changes:
     + Stop installing camerabin2 basecamerabin jpegformat - plugins which have
     moved to -good.
     + Provide gstreamer-plugins-bad-1.0.pc with Requires on
       gstreamer-plugins-good-1.0 - the package we've moved the referenced
       library to. This maintains compatibility with upstream software and
       other distributions.
     + debian/patches/adding-mirsink-and-android-media-over-hybris-support.patch:
       - Adding mirsink and Android media over hybris support, for hardware
         accelerated decode using libstagefright and the hybris compat layer.
     + debian/control.in:
       - Making the hybris plugin as part of a separated package, and i386 and
         armhf only (can only work with android compatible archs)
     + debian/build-deps.in:
       - Adding mirsink/android decoder specific build dependencies for i386 and
         armhf (libplatform-api1-dev and libmedia-dev)
 .
 gst-plugins-bad1.0 (1.2.2-1) unstable; urgency=medium
 .
   * New upstream bugfix release.
 .
 gst-plugins-bad1.0 (1.2.1-2) unstable; urgency=medium
 .
   * debian/rules,
     debian/gstreamer-plugins-bad.install:
     + Enable the OpenCV plugin again, now that all the linking errors are gone.


  gst-plugins-base1.0 (1.2.2-1ubuntu1) trusty; urgency=low
 .
   * Merge from Debian unstable.  Remaining changes:
     - Use dh_autoreconf --as-needed rather than disabling libtoolize and
       manually patching ltmain.sh, to pick up other libtool macro changes for
       new ports.
     - debian/patches/aarch64_fail_neon_check.patch: Disable NEON
       on arm64, as the assembly is ARMv7-specific.
 .
 gst-plugins-base1.0 (1.2.2-1) unstable; urgency=medium
 .
   * New upstream bugfix release:
     + debian/libgstreamer-plugins-base.symbols:
       - Add new 1.2.2 API additions.


  gst-plugins-good1.0 (1.2.2-1ubuntu1) trusty; urgency=low
 .
   * Merge from Debian unstable.  Remaining changes:
     + Import plugins from -bad that are needed for main applications.
       - jpegformat
       - camerabin2 (+ basecamerabinsrc + photography)
     + Break and Replace -bad versions which contained these plugins.
     + Add a library package containing the shared library and a -dev package for
       compiling against it. Add Breaks and Replaces against the plugins packages
       which formerly contained files shipped here.
     + Enable libtool during dh-autoreconf.
     + Remove as-needed patch, instead pass as-needed arg to dh_autoreconf.
     + Enable parallel build.
 .
 gst-plugins-good1.0 (1.2.2-1) unstable; urgency=medium
 .
   * New upstream bugfix release.
   * debian/build-deps.in:
     + Build-depend on libvpx-dev >= 1.3.0 for VP9 support.


 gstreamer1.0-hybris

  Changesfile not available.

  gzip (1.6-3ubuntu1) trusty; urgency=low
 .
   * Merge from Debian unstable (lp: #1264431).  Remaining changes:
     - debian/{control,rules}: Remove the Win32 build and mingw64
       build-dependency, since mingw is in universe, and will remain so for
       the forseeable future.
     - Added autopkgtest tests
 .
 gzip (1.6-3) unstable; urgency=low
 .
   * add a comment to the lintian overrides explaining them
   * updated rsyncable patch from Alexander Inyukhin, closesL #708423
   * never include dir.gz in package, closes: #720917


  history-service (0.1+14.04.20140110-0ubuntu1) trusty; urgency=low
 .
   [ Gustavo Pichorim Boiko ]
   * Rename the messageFlags field to messageStatus to reflect its real
     purpose.
   * Add tests for the Telepathy related code in history-service.
   * Handle the delivery reports and use the data to update the message
     status.
 .
   [ Tiago Salem Herrmann ]
   * Declare delivery report enums to be used from QML. Update all
     existing text message status to "accepted".
 .
   [ Ubuntu daily release ]
   * Automatic snapshot from revision 125


  language-pack-de (1:14.04+20140109) trusty; urgency=low
 .
   * Automatic update to latest translation data.


  language-pack-en (1:14.04+20140109) trusty; urgency=low
 .
   * Automatic update to latest translation data.


  language-pack-es (1:14.04+20140109) trusty; urgency=low
 .
   * Automatic update to latest translation data.


  language-pack-fr (1:14.04+20140109) trusty; urgency=low
 .
   * Automatic update to latest translation data.


  language-pack-gnome-de (1:14.04+20140109) trusty; urgency=low
 .
   * Automatic update to latest translation data.


  language-pack-gnome-en (1:14.04+20140109) trusty; urgency=low
 .
   * Automatic update to latest translation data.


  language-pack-gnome-es (1:14.04+20140109) trusty; urgency=low
 .
   * Automatic update to latest translation data.


  language-pack-gnome-fr (1:14.04+20140109) trusty; urgency=low
 .
   * Automatic update to latest translation data.


  language-pack-gnome-pt (1:14.04+20140109) trusty; urgency=low
 .
   * Automatic update to latest translation data.


  language-pack-gnome-zh-hans (1:14.04+20140109) trusty; urgency=low
 .
   * Automatic update to latest translation data.


  language-pack-pt (1:14.04+20140109) trusty; urgency=low
 .
   * Automatic update to latest translation data.


  language-pack-zh-hans (1:14.04+20140109) trusty; urgency=low
 .
   * Automatic update to latest translation data.


 libdatrie

  Changesfile not available.

  openssl (1.0.1f-1ubuntu1) trusty; urgency=low
 .
   * Merge with Debian, remaining changes.
     - debian/libssl1.0.0.postinst:
       + Display a system restart required notification on libssl1.0.0
         upgrade on servers.
       + Use a different priority for libssl1.0.0/restart-services depending
         on whether a desktop, or server dist-upgrade is being performed.
     - debian/{libssl1.0.0-udeb.dirs, control, rules}: Create
       libssl1.0.0-udeb, for the benefit of wget-udeb (no wget-udeb package
       in Debian).
     - debian/{libcrypto1.0.0-udeb.dirs, libssl1.0.0.dirs, libssl1.0.0.files,
       rules}: Move runtime libraries to /lib, for the benefit of
       wpasupplicant.
     - debian/patches/perlpath-quilt.patch: Don't change perl #! paths under
       .pc.
     - debian/rules:
       + Don't run 'make test' when cross-building.
       + Use host compiler when cross-building.  Patch from Neil Williams.
       + Don't build for processors no longer supported: i586 (on i386)
       + Fix Makefile to properly clean up libs/ dirs in clean target.
       + Replace duplicate files in the doc directory with symlinks.
     - debian/control: Mark Debian Vcs-* as XS-Debian-Vcs-*
     - debian/patches/ubuntu_deb676533_arm_asm.patch: Enable arm assembly
       code.
     - debian/rules: Enable optimized 64bit elliptic curve code contributed
       by Google.
   * Dropped changes:
     - debian/patches/arm64-support: included in debian-targets.patch
     - debian/patches/no_default_rdrand.patch: upstream
     - debian/patches/openssl-1.0.1e-env-zlib.patch: zlib is now completely
       disabled in debian/rules
 .
 openssl (1.0.1f-1) unstable; urgency=high
 .
   * New upstream version
     - Fix for TLS record tampering bug CVE-2013-4353
     - Drop the snapshot patch
   * update watch file to check for upstream signature and add upstream pgp key.
   * Drop conflicts against openssh since we now on a released version again.
 .
 openssl (1.0.1e-6) unstable; urgency=medium
 .
   * Add Breaks: openssh-client (<< 1:6.4p1-1.1), openssh-server (<<
     1:6.4p1-1.1).  This is to prevent people running into #732940.
     This Breaks can be removed again when we stop using a git snapshot.
 .
 openssl (1.0.1e-5) unstable; urgency=low
 .
   * Change default digest to SHA256 instead of SHA1.  (Closes: #694738)
   * Drop support for multiple certificates in 1 file.  It never worked
     properly in the first place, and the only one shipping in
     ca-certificates has been split.
   * Fix libdoc-manpgs-pod-spell.patch to only fix spalling errors
   * Remove make-targets.patch.  It prevented the test dir from being cleaned.
   * Update to a git snapshot of the OpenSSL_1_0_1-stable branch.
     - Fixes CVE-2013-6449 (Closes: #732754)
     - Fixes CVE-2013-6450
     - Drop patches ssltest_no_sslv2.patch cpuid.patch aesni-mac.patch
       dtls_version.patch get_certificate.patch, since they where all
       already commited upstream.
     - adjust fix-pod-errors.patch for the reordering of items in the
       documentation they've done trying to fix those pod errors.
     - disable rdrand engine by default (Closes: #732710)
   * disable zlib support.  Fixes CVE-2012-4929 (Closes: #728055)
   * Add arm64 support (Closes: #732348)
   * Properly use the default number of bits in req when none are given


  pygobject (3.11.3-0ubuntu1) trusty; urgency=medium
 .
   * New upstream release.
     - Warn about wrong positional GObject constructor arguments (they are
       all deprecated now). (LP: #1248152)


  software-properties (0.92.31) trusty; urgency=medium
 .
   * Stop using deprecated GObject constructors with positional arguments.
     (https://wiki.gnome.org/PyGObject/InitializerDeprecations)


  systemd (204-5ubuntu7) trusty; urgency=medium
 .
   * Enable all cgroup controllers in logind.conf. This is needed so that
     unprivileged LXC may work.


  telepathy-ofono (0.2+14.04.20140110-0ubuntu1) trusty; urgency=low
 .
   [ Tiago Salem Herrmann ]
   * Add delivery report support.
 .
   [ Ubuntu daily release ]
   * Automatic snapshot from revision 57


  ubuntu-system-settings (0.1+14.04.20140110-0ubuntu1) trusty; urgency=low
 .
   [ William Hua ]
   * Enable auto-completion and predictive text settings.