CVE-2017-9023

Priority
Medium
Description
The ASN.1 parser in strongSwan before 5.5.3 improperly handles CHOICE types
when the x509 plugin is enabled, which allows remote attackers to cause a
denial of service (infinite loop) via a crafted certificate.
References
Assigned-to
mdeslaur
Package
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):released (5.5.1-4ubuntu1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (5.1.2-0ubuntu2.6)
Ubuntu Touch 15.04:DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (5.3.5-1ubuntu3.3)
Ubuntu 16.10 (Yakkety Yak):released (5.3.5-1ubuntu4.3)
Ubuntu 17.04 (Zesty Zapus):released (5.5.1-1ubuntu3.1)
More Information

Updated: 2017-06-14 22:14:42 UTC (commit 12736)