CVE-2017-7619

Priority
Low
Description
In ImageMagick 7.0.4-9, an infinite loop can occur because of a
floating-point rounding error in some of the color algorithms. This affects
ModulateHSL, ModulateHCL, ModulateHCLp, ModulateHSB, ModulateHSI,
ModulateHSV, ModulateHWB, ModulateLCHab, and ModulateLCHuv.
References
Bugs
Notes
 mdeslaur> This is 0192-Fix-CVE-2017-7619.patch
Package
Upstream:needed
Ubuntu 17.10 (Artful Aardvark):released (8:6.9.7.4+dfsg-9ubuntu1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):released (8:6.7.7.10-6ubuntu3.7)
Ubuntu Touch 15.04:DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (8:6.8.9.9-7ubuntu5.7)
Ubuntu 16.10 (Yakkety Yak):released (8:6.8.9.9-7ubuntu8.6)
Ubuntu 17.04 (Zesty Zapus):released (8:6.9.7.4+dfsg-3ubuntu1.1)
Patches:
Upstream:http://git.imagemagick.org/repos/ImageMagick/commit/63757068c803f692bd70304b06ce3406e0b67c7f
More Information

Updated: 2017-05-31 13:14:36 UTC (commit 12650)