CVE-2017-7606

Priority
Low
Description
coders/rle.c in ImageMagick 7.0.5-4 has an "outside the range of
representable values of type unsigned char" undefined behavior issue, which
might allow remote attackers to cause a denial of service (application
crash) or possibly have unspecified other impact via a crafted image.
References
Bugs
Notes
 mdeslaur> This is 0191-Fix-CVE-2017-7606.patch
Assigned-to
mdeslaur
Package
Upstream:needed
Ubuntu 17.10 (Artful Aardvark):released (8:6.9.7.4+dfsg-9ubuntu1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):released (8:6.7.7.10-6ubuntu3.7)
Ubuntu Touch 15.04:DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (8:6.8.9.9-7ubuntu5.7)
Ubuntu 16.10 (Yakkety Yak):released (8:6.8.9.9-7ubuntu8.6)
Ubuntu 17.04 (Zesty Zapus):released (8:6.9.7.4+dfsg-3ubuntu1.1)
Patches:
Upstream:https://github.com/ImageMagick/ImageMagick/commit/b218117cad34d39b9ffb587b45c71c5a49b12bde
More Information

Updated: 2017-05-31 13:14:36 UTC (commit 12650)