CVE-2016-9942

Priority
Medium
Description
Heap-based buffer overflow in ultra.c in LibVNCClient in LibVNCServer
before 0.9.11 allows remote servers to cause a denial of service
(application crash) or possibly execute arbitrary code via a crafted
FramebufferUpdate message with the Ultra type tile, such that the LZO
payload decompressed length exceeds what is specified by the tile
dimensions.
References
Bugs
Assigned-to
mdeslaur
Package
Upstream:released (0.9.11)
Ubuntu 12.04 LTS (Precise Pangolin):released (0.9.8.2-2ubuntu1.2)
Ubuntu 14.04 LTS (Trusty Tahr):released (0.9.9+dfsg-1ubuntu1.2)
Ubuntu Touch 15.04:DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (0.9.10+dfsg-3ubuntu0.16.04.1)
Ubuntu 16.10 (Yakkety Yak):released (0.9.10+dfsg-3ubuntu0.16.10.1)
Ubuntu 17.04 (Zesty Zapus):not-affected (0.9.11+dfsg-1)
Patches:
Upstream:https://github.com/LibVNC/libvncserver/commit/5fff4353f66427b467eb29e5fdc1da4f2be028bb
More Information

Updated: 2017-01-11 19:14:32 UTC (commit 11947)