CVE-2016-9933

Priority
Low
Description
Stack consumption vulnerability in the gdImageFillToBorder function in gd.c
in the GD Graphics Library (aka libgd) before 2.2.2, as used in PHP before
5.6.28 and 7.x before 7.0.13, allows remote attackers to cause a denial of
service (segmentation violation) via a crafted imagefilltoborder call that
triggers use of a negative color value.
References
Bugs
Notes
 mdeslaur> php uses the system libgd2
Assigned-to
mdeslaur
Package
Upstream:released (2.2.2)
Ubuntu 12.04 LTS (Precise Pangolin):released (2.0.36~rc1~dfsg-6ubuntu2.4)
Ubuntu 14.04 LTS (Trusty Tahr):released (2.1.0-3ubuntu0.6)
Ubuntu Touch 15.04:DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (2.1.1-4ubuntu0.16.04.6)
Ubuntu 16.10 (Yakkety Yak):released (2.2.1-1ubuntu3.3)
Ubuntu 17.04 (Zesty Zapus):not-affected (2.2.3-87-gd0fec80-3)
Patches:
Upstream:https://github.com/libgd/libgd/commit/77f619d48259383628c3ec4654b1ad578e9eb40e
Package
Source: php5 (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 LTS (Precise Pangolin):not-affected (uses system gd)
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (uses system gd)
Ubuntu Touch 15.04:DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 16.10 (Yakkety Yak):DNE
Ubuntu 17.04 (Zesty Zapus):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 LTS (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu Touch 15.04:DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (uses system gd)
Ubuntu 16.10 (Yakkety Yak):not-affected (uses system gd)
Ubuntu 17.04 (Zesty Zapus):not-affected (uses system gd)
More Information

Updated: 2017-02-28 20:14:32 UTC (commit 12163)