CVE-2016-9429

Priority
Medium
Description
An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31.
Buffer overflow in the formUpdateBuffer function in w3m allows remote
attackers to cause a denial of service (crash) and possibly execute
arbitrary code via a crafted HTML page.
References
Package
Source: w3m (LP Ubuntu Debian)
Upstream:released (0.5.3-30)
Ubuntu 12.04 LTS (Precise Pangolin):released (0.5.3-5ubuntu1.2)
Ubuntu 14.04 LTS (Trusty Tahr):released (0.5.3-15ubuntu0.1)
Ubuntu Touch 15.04:DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (0.5.3-26ubuntu0.1)
Ubuntu 16.10 (Yakkety Yak):needed
Ubuntu 17.04 (Zesty Zapus):not-affected (0.5.3-32)
Patches:
Debian:https://github.com/tats/w3m/commit/d01de738f599441740437c6600dd5b1ae7155d27
More Information

Updated: 2017-03-02 16:14:35 UTC (commit 12171)