CVE-2016-8687

Priority
Low
Description
Stack-based buffer overflow in the safe_fprintf function in tar/util.c in
libarchive 3.2.1 allows remote attackers to cause a denial of service via a
crafted non-printable multibyte character in a filename.
References
Bugs
Package
Upstream:released (3.2.1-5)
Ubuntu 12.04 LTS (Precise Pangolin):released (3.0.3-6ubuntu1.4)
Ubuntu 14.04 LTS (Trusty Tahr):released (3.1.2-7ubuntu2.4)
Ubuntu Touch 15.04:DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (3.1.2-11ubuntu0.16.04.3)
Ubuntu 16.10 (Yakkety Yak):released (3.2.1-2ubuntu0.1)
Ubuntu 17.04 (Zesty Zapus):not-affected (3.2.1-6)
Patches:
Upstream:https://github.com/libarchive/libarchive/commit/e37b620fe8f14535d737e89a4dcabaed4517bf1a
More Information

Updated: 2017-03-09 19:14:34 UTC (commit 12215)