CVE-2016-7166

Priority
Medium
Description
libarchive before 3.2.0 does not limit the number of recursive
decompressions, which allows remote attackers to cause a denial of service
(memory consumption and application crash) via a crafted gzip file.
References
Bugs
Package
Upstream:released (3.2.0-2)
Ubuntu 12.04 LTS (Precise Pangolin):released (3.0.3-6ubuntu1.4)
Ubuntu 14.04 LTS (Trusty Tahr):released (3.1.2-7ubuntu2.4)
Ubuntu Touch 15.04:DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (3.1.2-11ubuntu0.16.04.3)
Ubuntu 16.10 (Yakkety Yak):not-affected (3.2.1-2)
Ubuntu 17.04 (Zesty Zapus):not-affected (3.2.1-2)
Patches:
Upstream:https://github.com/libarchive/libarchive/commit/6e06b1c89dd0d16f74894eac4cfc1327a06ee4a0
Upstream:https://github.com/libarchive/libarchive/commit/37649d274867edd2dd25d8a3057c3b6cd81ce83e (not needed)
More Information

Updated: 2017-03-09 19:14:34 UTC (commit 12215)