CVE-2016-6250

Priority
Low
Description
Integer overflow in the ISO9660 writer in libarchive before 3.2.1 allows
remote attackers to cause a denial of service (application crash) or
execute arbitrary code via vectors related to verifying filename lengths
when writing an ISO9660 archive, which trigger a buffer overflow.
References
Bugs
Package
Upstream:released (3.2.1-1)
Ubuntu 12.04 LTS (Precise Pangolin):released (3.0.3-6ubuntu1.4)
Ubuntu 14.04 LTS (Trusty Tahr):released (3.1.2-7ubuntu2.4)
Ubuntu Touch 15.04:DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (3.1.2-11ubuntu0.16.04.3)
Ubuntu 16.10 (Yakkety Yak):not-affected (3.2.1-1)
Ubuntu 17.04 (Zesty Zapus):not-affected (3.2.1-1)
Patches:
Upstream:https://github.com/libarchive/libarchive/commit/3014e19820ea53c15c90f9d447ca3e668a0b76c6
More Information

Updated: 2017-03-09 19:14:34 UTC (commit 12215)