CVE-2015-3246

Priority
Description
libuser before 0.56.13-8 and 0.60 before 0.60-7, as used in the userhelper
program in the usermode package, directly modifies /etc/passwd, which
allows local users to cause a denial of service (inconsistent file state)
by causing an error during the modification. NOTE: this issue can be
combined with CVE-2015-3245 to gain privileges.
Package
Upstream:released (1:0.62~dfsg-0.1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1:0.62~dfsg-0.1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1:0.62~dfsg-0.1)
Ubuntu 19.04 (Disco Dingo):not-affected (1:0.62~dfsg-0.1)
Patches:
Upstream:https://fedorahosted.org/libuser/changeset/d73aa2a5a9ce5bdd349dff46e3e4885f2b194a95/
More Information

Updated: 2019-01-14 21:17:05 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)