CVE-2014-9911

Priority
Medium
Description
Stack-based buffer overflow in the ures_getByKeyWithFallback function in
common/uresbund.cpp in International Components for Unicode (ICU) before
54.1 for C/C++ allows remote attackers to cause a denial of service or
possibly have unspecified other impact via a crafted uloc_getDisplayName
call.
References
Notes
 jdstrand> this was fixed in 54.0.1. chromium-browser has 56 now
 chrisccoulson> firefox has 56 at least since Firefox 50, and Thunderbird
  has 56 since at least 45.3
 chrisccoulson> oxide has had 56.1 since at least 1.17
Package
Upstream:not-affected (50.1.0)
Ubuntu 17.10 (Artful Aardvark):not-affected (50.1.0+build2-0ubuntu1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was not-affected [50.1.0+build2-0ubuntu0.12.04.1])
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (50.1.0+build2-0ubuntu0.14.04.1)
Ubuntu Touch 15.04:DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (50.1.0+build2-0ubuntu0.16.04.1)
Ubuntu 16.10 (Yakkety Yak):not-affected (50.1.0+build2-0ubuntu0.16.10.1)
Ubuntu 17.04 (Zesty Zapus):not-affected (50.1.0+build2-0ubuntu1)
Package
Upstream:not-affected (1.17.9)
Ubuntu 17.10 (Artful Aardvark):not-affected (1.17.9-0ubuntu1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (1.17.9-0ubuntu0.14.04.1)
Ubuntu Touch 15.04:not-affected (1.17.9-0ubuntu0.15.04.1~overlay2)
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1.17.9-0ubuntu0.16.04.1)
Ubuntu 16.10 (Yakkety Yak):not-affected (1.17.9-0ubuntu1)
Ubuntu 17.04 (Zesty Zapus):not-affected (1.17.9-0ubuntu1)
Package
Upstream:not-affected (45.3.0)
Ubuntu 17.10 (Artful Aardvark):not-affected (1:45.3.0+build1-0ubuntu4)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was not-affected [1:45.3.0+build1-0ubuntu0.12.04.1])
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (1:45.3.0+build1-0ubuntu0.14.04.4)
Ubuntu Touch 15.04:DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1:45.3.0+build1-0ubuntu0.16.04.2)
Ubuntu 16.10 (Yakkety Yak):not-affected (1:45.3.0+build1-0ubuntu4)
Ubuntu 17.04 (Zesty Zapus):not-affected (1:45.3.0+build1-0ubuntu4)
Package
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):not-affected
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was ignored)
Ubuntu 14.04 LTS (Trusty Tahr):not-affected
Ubuntu Touch 15.04:DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected
Ubuntu 16.10 (Yakkety Yak):not-affected
Ubuntu 17.04 (Zesty Zapus):not-affected
Package
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu Touch 15.04:DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 16.10 (Yakkety Yak):needed
Ubuntu 17.04 (Zesty Zapus):needed
Package
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu Touch 15.04:needed
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 16.10 (Yakkety Yak):needed
Ubuntu 17.04 (Zesty Zapus):needed
Package
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu Touch 15.04:DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 16.10 (Yakkety Yak):needs-triage
Ubuntu 17.04 (Zesty Zapus):needs-triage
Package
Source: icu (LP Ubuntu Debian)
Upstream:released (55.1-3)
Ubuntu 17.10 (Artful Aardvark):not-affected
Ubuntu 12.04 ESM (Precise Pangolin):released (4.8.1.1-3ubuntu0.7)
Ubuntu 14.04 LTS (Trusty Tahr):released (52.1-3ubuntu0.5)
Ubuntu Touch 15.04:needs-triage
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (55.1-7)
Ubuntu 16.10 (Yakkety Yak):not-affected
Ubuntu 17.04 (Zesty Zapus):not-affected
Patches:
Upstream:http://bugs.icu-project.org/trac/changeset/35699
More Information

Updated: 2017-05-10 22:19:59 UTC (commit 12521)