CVE-2014-5033

Priority
Medium
Description
KDE kdelibs before 4.14 and kauth before 5.1 does not properly use D-Bus
for communication with a polkit authority, which allows local users to
bypass intended access restrictions by leveraging a PolkitUnixProcess
PolkitSubject race condition via a (1) setuid process or (2) pkexec
process, related to CVE-2013-4288 and "PID reuse race conditions."
References
Bugs
Package
Upstream:needed
Ubuntu 10.04 LTS (Lucid Lynx):ignored (reached end-of-life)
Ubuntu 12.04 LTS (Precise Pangolin):released (4:4.8.5-0ubuntu0.4)
Ubuntu 14.04 LTS (Trusty Tahr):released (4:4.13.2a-0ubuntu0.3)
Ubuntu 14.10 (Utopic Unicorn):not-affected (4:4.13.95-0ubuntu3)
Patches:
Upstream:http://quickgit.kde.org/?p=kdelibs.git&a=commit&h=e4e7b53b71e2659adaf52691d4accc3594203b23
More Information

Valid XHTML 1.0 Strict

Updated: 2014-08-20 21:14:38 UTC (commit 8395)