CVE-2014-3609

Priority
Medium
Description
HttpHdrRange.cc in Squid 3.x before 3.3.12 and 3.4.x before 3.4.6 allows
remote attackers to cause a denial of service (crash) via a request with
crafted "Range headers with unidentifiable byte-range values."
References
Assigned-to
jdstrand
Package
Upstream:needs-triage
Ubuntu 10.04 LTS (Lucid Lynx):ignored (reached end-of-life)
Ubuntu 12.04 LTS (Precise Pangolin):released (3.1.19-1ubuntu3.12.04.3)
Ubuntu 14.04 LTS (Trusty Tahr):released (3.3.8-1ubuntu6.1)
Ubuntu 14.10 (Utopic Unicorn):released (3.3.8-1ubuntu8)
Patches:
Upstream:http://www.squid-cache.org/Versions/v3/3.3/changesets/squid-3.3-12680.patch (3.3)
Upstream:http://www.squid-cache.org/Versions/v3/3.1/changesets/squid-3.1-10488.patch (3.1)
More Information

Valid XHTML 1.0 Strict

Updated: 2014-09-18 02:14:47 UTC (commit 8497)