CVE-2014-3594

Priority
Medium
Description
Cross-site scripting (XSS) vulnerability in the Host Aggregates interface
in OpenStack Dashboard (Horizon) before 2013.2.4, 2014.1 before 2014.1.2,
and Juno before Juno-3 allows remote administrators to inject arbitrary web
script or HTML via a new host aggregate name.
References
Bugs
Notes
jdstrand> Horizon on Essex (Ubuntu 12.04) does not have the Host Aggregate
interface
Assigned-to
jdstrand
Package
Upstream:needs-triage
Ubuntu 10.04 LTS (Lucid Lynx):DNE
Ubuntu 12.04 LTS (Precise Pangolin):not-affected (code-not-present)
Ubuntu 14.04 LTS (Trusty Tahr):released (1:2014.1.2-0ubuntu1.1)
Ubuntu 14.10 (Utopic Unicorn):needed
Patches:
Upstream:https://review.openstack.org/115313 (havana)
Upstream:https://review.openstack.org/115311 (icehouse)
Upstream:https://review.openstack.org/115310 (juno)
More Information

Valid XHTML 1.0 Strict

Updated: 2014-08-28 06:14:20 UTC (commit 8426)