CVE-2014-3512

Priority
Medium
Description
Multiple buffer overflows in crypto/srp/srp_lib.c in the SRP implementation
in OpenSSL 1.0.1 before 1.0.1i allow remote attackers to cause a denial of
service (application crash) or possibly have unspecified other impact via
an invalid SRP (1) g, (2) A, or (3) B parameter.
References
Assigned-to
mdeslaur
Package
Upstream:not-affected
Ubuntu 10.04 LTS (Lucid Lynx):DNE
Ubuntu 12.04 LTS (Precise Pangolin):not-affected
Ubuntu 14.04 LTS (Trusty Tahr):not-affected
Ubuntu 14.10 (Utopic Unicorn):not-affected
Package
Upstream:released (1.0.1i)
Ubuntu 10.04 LTS (Lucid Lynx):not-affected
Ubuntu 12.04 LTS (Precise Pangolin):released (1.0.1-4ubuntu5.17)
Ubuntu 14.04 LTS (Trusty Tahr):released (1.0.1f-1ubuntu2.5)
Ubuntu 14.10 (Utopic Unicorn):released (1.0.1f-1ubuntu7)
Patches:
Upstream:https://git.openssl.org/gitweb/?p=openssl.git;a=commit;h=966fe81f9befbff62522a158006fb03050a868df (1.0.1)
Upstream:https://git.openssl.org/gitweb/?p=openssl.git;a=commit;h=d15d17bb6487a3e7b59a22882b6a22300fe5111d (1.0.1)
More Information

Valid XHTML 1.0 Strict

Updated: 2014-08-20 21:14:37 UTC (commit 8395)