CVE-2014-3505

Priority
Medium
Description
Double free vulnerability in d1_both.c in the DTLS implementation in
OpenSSL 0.9.8 before 0.9.8zb, 1.0.0 before 1.0.0n, and 1.0.1 before 1.0.1i
allows remote attackers to cause a denial of service (application crash)
via crafted DTLS packets that trigger an error condition.
References
Assigned-to
mdeslaur
Package
Upstream:released (0.9.8zb)
Ubuntu 10.04 LTS (Lucid Lynx):DNE
Ubuntu 12.04 LTS (Precise Pangolin):needed
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 14.10 (Utopic Unicorn):needed
Package
Upstream:released (0.9.8zb,1.0.1i)
Ubuntu 10.04 LTS (Lucid Lynx):released (0.9.8k-7ubuntu8.20)
Ubuntu 12.04 LTS (Precise Pangolin):released (1.0.1-4ubuntu5.17)
Ubuntu 14.04 LTS (Trusty Tahr):released (1.0.1f-1ubuntu2.5)
Ubuntu 14.10 (Utopic Unicorn):released (1.0.1f-1ubuntu7)
Patches:
Upstream:https://git.openssl.org/gitweb/?p=openssl.git;a=commit;h=2172d4f63c61922487008f42511cc6bdae9b47a0 (1.0.1)
Upstream:https://git.openssl.org/gitweb/?p=openssl.git;a=commit;h=e7b9d9be48cdc598a46c8e1536035ed29a9af254 (1.0.1)
Upstream:https://git.openssl.org/gitweb/?p=openssl.git;a=commit;h=1b7024fb69161619855d86b80ae0681ea802e245 (0.9.8)
Upstream:https://git.openssl.org/gitweb/?p=openssl.git;a=commit;h=6a431cd293b283b0c7d2b40faa77f8244a27462f (0.9.8)
More Information

Valid XHTML 1.0 Strict

Updated: 2014-10-23 21:18:42 UTC (commit 8644)