CVE-2014-3474

Priority
Medium
Description
Cross-site scripting (XSS) vulnerability in
horizon/static/horizon/js/horizon.instances.js in the Launch Instance menu
in OpenStack Dashboard (Horizon) before 2013.2.4, 2014.1 before 2014.1.2,
and Juno before Juno-2 allows remote authenticated users to inject
arbitrary web script or HTML via a network name.
References
Bugs
Notes
mdeslaur> same patches as CVE-2014-3473
mdeslaur> introduced by:
mdeslaur> https://review.openstack.org/gitweb?p=openstack/horizon.git;h=8914ed95
Assigned-to
jdstrand
Package
Upstream:released (2013.2.4,2014.1.2,2014.1.1-3)
Ubuntu 10.04 LTS (Lucid Lynx):DNE
Ubuntu 12.04 LTS (Precise Pangolin):not-affected (2012.1.3+stable-20130423-5ce39422-0ubuntu1)
Ubuntu 14.04 LTS (Trusty Tahr):released (1:2014.1.2-0ubuntu1)
Ubuntu 14.10 (Utopic Unicorn):not-affected (1:2014.2~b2-0ubuntu1)
More Information

Valid XHTML 1.0 Strict

Updated: 2014-11-05 22:14:38 UTC (commit 8689)