CVE-2014-3468

Priority
Medium
Description
The asn1_get_bit_der function in GNU Libtasn1 before 3.6 does not properly
report an error when a negative bit length is identified, which allows
context-dependent attackers to cause out-of-bounds access via crafted ASN.1
data.
References
Bugs
Assigned-to
mdeslaur
Package
Upstream:needs-triage
Ubuntu 10.04 LTS (Lucid Lynx):released (2.4-1ubuntu0.2)
Ubuntu 12.04 LTS (Precise Pangolin):released (2.10-1ubuntu1.2)
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 14.10 (Utopic Unicorn):DNE
Package
Upstream:released (3.6)
Ubuntu 10.04 LTS (Lucid Lynx):DNE
Ubuntu 12.04 LTS (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (3.4-3ubuntu0.1)
Ubuntu 14.10 (Utopic Unicorn):not-affected (3.6-1)
Patches:
Upstream:http://git.savannah.gnu.org/cgit/libtasn1.git/commit/?id=1c3ccb3e040bf13e342ee60bc23b21b97b11923f
More Information

Valid XHTML 1.0 Strict

Updated: 2014-07-22 19:14:31 UTC (commit 8267)