CVE-2014-3248

Priority
Low
Description
Untrusted search path vulnerability in Puppet Enterprise 2.8 before 2.8.7,
Puppet before 2.7.26 and 3.x before 3.6.2, Facter 1.6.x and 2.x before
2.0.2, Hiera before 1.3.4, and Mcollective before 2.5.2, when running with
Ruby 1.9.1 or earlier, allows local users to gain privileges via a Trojan
horse file in the current working directory, as demonstrated using (1)
rubygems/defaults/operating_system.rb, (2) Win32API.rb, (3) Win32API.so,
(4) safe_yaml.rb, (5) safe_yaml/deep.rb, or (6) safe_yaml/deep.so; or (7)
operatingsystem.rb, (8) operatingsystem.so, (9) osfamily.rb, or (10)
osfamily.so in puppet/confine.
References
Package
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):DNE
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu Touch 15.04:DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 16.10 (Yakkety Yak):DNE
Ubuntu 17.04 (Zesty Zapus):DNE
Package
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):not-affected (3.8.5-2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):released (3.4.3-1ubuntu1.2)
Ubuntu Touch 15.04:DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (3.8.5-2)
Ubuntu 16.10 (Yakkety Yak):not-affected (3.8.5-2)
Ubuntu 17.04 (Zesty Zapus):not-affected (3.8.5-2)
Patches:
Upstream:https://github.com/puppetlabs/puppet/commit/1d1e1eac451fdd277ff1601b3fb635dcb713c7be
Package
Upstream:released (2.0.1-1)
Ubuntu 17.10 (Artful Aardvark):not-affected (2.0.1-1ubuntu1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu Touch 15.04:DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2.0.1-1ubuntu1)
Ubuntu 16.10 (Yakkety Yak):not-affected (2.0.1-1ubuntu1)
Ubuntu 17.04 (Zesty Zapus):not-affected (2.0.1-1ubuntu1)
Package
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu Touch 15.04:DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 16.10 (Yakkety Yak):needed
Ubuntu 17.04 (Zesty Zapus):needed
More Information

Updated: 2017-06-05 18:14:13 UTC (commit 12681)