CVE-2014-3152

Priority
Medium
Description
Integer underflow in the LCodeGen::PrepareKeyedOperand function in
arm/lithium-codegen-arm.cc in Google V8 before 3.25.28.16, as used in
Google Chrome before 35.0.1916.114, allows remote attackers to cause a
denial of service or possibly have unspecified other impact via vectors
that trigger a negative key value.
References
Package
Upstream:needs-triage
Ubuntu 12.04 LTS (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 15.04 (Vivid Vervet):DNE
Ubuntu 15.10 (Wily Werewolf):DNE
Package
Upstream:released (35.0.1916.114)
Ubuntu 12.04 LTS (Precise Pangolin):released (36.0.1985.125-0ubuntu1.12.04.0~pkg897)
Ubuntu 14.04 LTS (Trusty Tahr):released (36.0.1985.125-0ubuntu1.14.04.0~pkg1029)
Ubuntu 15.04 (Vivid Vervet):released (35.0.1916.153-0ubuntu1~pkg1029)
Ubuntu 15.10 (Wily Werewolf):released (35.0.1916.153-0ubuntu1~pkg1029)
Package
Upstream:needed
Ubuntu 12.04 LTS (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 15.04 (Vivid Vervet):needed
Ubuntu 15.10 (Wily Werewolf):needed
Package
Source: libv8 (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 LTS (Precise Pangolin):needed
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 15.04 (Vivid Vervet):DNE
Ubuntu 15.10 (Wily Werewolf):DNE
Package
Upstream:released (1.0.4)
Ubuntu 12.04 LTS (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (1.0.4-0ubuntu0.14.04.1)
Ubuntu 15.04 (Vivid Vervet):released (1.1.0~bzr640-0ubuntu1)
Ubuntu 15.10 (Wily Werewolf):released (1.1.0~bzr640-0ubuntu1)
More Information

Valid XHTML 1.0 Strict

Updated: 2015-07-29 20:21:42 UTC (commit 9756)