CVE-2014-3146

Priority
Medium
Description
Incomplete blacklist vulnerability in the lxml.html.clean module in lxml
before 3.3.5 allows remote attackers to conduct cross-site scripting (XSS)
attacks via control characters in the link scheme to the clean_html
function.
References
Bugs
Assigned-to
mdeslaur
Package
Source: lxml (LP Ubuntu Debian)
Upstream:released (3.3.5)
Ubuntu 10.04 LTS (Lucid Lynx):ignored (reached end-of-life)
Ubuntu 12.04 LTS (Precise Pangolin):released (2.3.2-1ubuntu0.2)
Ubuntu 13.10 (Saucy Salamander):released (3.2.0-1ubuntu0.1)
Ubuntu 14.04 LTS (Trusty Tahr):released (3.3.3-1ubuntu0.1)
Ubuntu 14.10 (Utopic Unicorn):not-affected (3.3.5-1)
Patches:
Upstream:https://github.com/lxml/lxml/commit/e86b294f1f81b899a59925123560ff924a72f1cc
More Information

Valid XHTML 1.0 Strict

Updated: 2014-05-21 16:14:27 UTC (commit 8081)