CVE-2014-2270

Priority
Medium
Description
softmagic.c in file before 5.17 and libmagic allows context-dependent
attackers to cause a denial of service (out-of-bounds memory access and
crash) via crafted offsets in the softmagic of a PE executable.
References
Bugs
Notes
mdeslaur> see regression fix in DSA-2873-2
mdeslaur> The regression in the debian package is caused by a fix for
mdeslaur> a different issue which does not seem to have a CVE number:
mdeslaur> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=703993
mdeslaur> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=742262 (file regression 1)
mdeslaur> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=742265 (file regression 2)
Assigned-to
mdeslaur
Package
Source: php5 (LP Ubuntu Debian)
Upstream:released (5.5.10)
Ubuntu 10.04 LTS (Lucid Lynx):released (5.3.2-1ubuntu4.24)
Ubuntu 12.04 LTS (Precise Pangolin):released (5.3.10-1ubuntu3.11)
Ubuntu 12.10 (Quantal Quetzal):released (5.4.6-1ubuntu1.8)
Ubuntu 13.10 (Saucy Salamander):released (5.5.3+dfsg-1ubuntu2.3)
Ubuntu 14.04 LTS (Trusty Tahr):released (5.5.9+dfsg-1ubuntu3)
Patches:
Upstream:http://git.php.net/?p=php-src.git;a=commitdiff;h=a33759fd275b32ed0bbe89796fe2953b3cb0b41f
Package
Source: file (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 10.04 LTS (Lucid Lynx):released (5.03-5ubuntu1.2)
Ubuntu 12.04 LTS (Precise Pangolin):released (5.09-2ubuntu0.3)
Ubuntu 12.10 (Quantal Quetzal):released (5.11-2ubuntu0.2)
Ubuntu 13.10 (Saucy Salamander):released (5.11-2ubuntu4.2)
Ubuntu 14.04 LTS (Trusty Tahr):released (1:5.14-2ubuntu3)
Patches:
Upstream:https://github.com/file/file/commit/447558595a3650db2886cd2f416ad0beba965801
Upstream:https://github.com/file/file/commit/70c65d2e1841491f59168db1f905e8b14083fb1c
More Information

Valid XHTML 1.0 Strict

Updated: 2014-04-07 14:14:42 UTC (commit 7918)