CVE-2014-0475

Priority
Medium
Description
Multiple directory traversal vulnerabilities in GNU C Library (aka glibc or
libc6) before 2.20 allow context-dependent attackers to bypass ForceCommand
restrictions and possibly have other unspecified impact via a .. (dot dot)
in a (1) LC_*, (2) LANG, or other locale environment variable.
References
Bugs
Notes
The fix for this introduced a localplt regression
Package
Upstream:released (2.19-7)
Ubuntu 10.04 LTS (Lucid Lynx):released (2.11.1-0ubuntu7.14)
Ubuntu 12.04 LTS (Precise Pangolin):released (2.15-0ubuntu10.6)
Ubuntu 14.04 LTS (Trusty Tahr):released (2.19-0ubuntu6.1)
Ubuntu 14.10 (Utopic Unicorn):ignored
Package
Source: glibc (LP Ubuntu Debian)
Upstream:released (2.19-6)
Ubuntu 10.04 LTS (Lucid Lynx):DNE
Ubuntu 12.04 LTS (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 14.10 (Utopic Unicorn):released (2.19-10ubuntu1)
Patches:
Upstream:https://sourceware.org/git/?p=glibc.git;h=4e8f95a0df7c2300b830ec12c0ae1e161bc8a8a3
Upstream:https://sourceware.org/git/?p=glibc.git;h=585367266923156ac6fb789939a923641ba5aaf4 (doc)
Upstream:https://sourceware.org/git/?p=glibc.git;h=d183645616b0533b3acee28f1a95570bffbdf50f
Upstream:https://sourceware.org/git/?p=glibc.git;h=ca38dc17d85b09776a709c8ea7155c414df14073 (regression fix)
More Information

Valid XHTML 1.0 Strict

Updated: 2014-09-02 15:14:41 UTC (commit 8434)