CVE-2014-0240

Priority
Medium
Description
The mod_wsgi module before 3.5 for Apache, when daemon mode is enabled,
does not properly handle error codes returned by setuid when run on certain
Linux kernels, which allows local users to gain privileges via vectors
related to the number of running processes.
References
Bugs
Notes
mdeslaur> from upstream: The issue is believed to affect Linux systems
mdeslaur> running kernel versions >= 2.6.0 and < 3.1.0.
Package
Upstream:released (3.5-1)
Ubuntu 10.04 LTS (Lucid Lynx):ignored (reached end-of-life)
Ubuntu 12.04 LTS (Precise Pangolin):released (3.3-4ubuntu0.1)
Ubuntu 13.10 (Saucy Salamander):released (3.4-4ubuntu2.1.13.10.1)
Ubuntu 14.04 LTS (Trusty Tahr):released (3.4-4ubuntu2.1.14.04.1)
Ubuntu 14.10 (Utopic Unicorn):released (3.5-1)
Patches:
Upstream:https://github.com/GrahamDumpleton/mod_wsgi/commit/d9d5fea585b23991f76532a9b07de7fcd3b649f4
More Information

Valid XHTML 1.0 Strict

Updated: 2014-05-28 08:14:24 UTC (commit 8096)