CVE-2014-0224

Priority
Medium
Description
OpenSSL before 0.9.8za, 1.0.0 before 1.0.0m, and 1.0.1 before 1.0.1h does
not properly restrict processing of ChangeCipherSpec messages, which allows
man-in-the-middle attackers to trigger use of a zero-length master key in
certain OpenSSL-to-OpenSSL communications, and consequently hijack sessions
or obtain sensitive information, via a crafted TLS handshake, aka the "CCS
Injection" vulnerability.
References
Assigned-to
mdeslaur
Package
Upstream:released (0.9.8za)
Ubuntu 10.04 LTS (Lucid Lynx):DNE
Ubuntu 12.04 LTS (Precise Pangolin):released (0.9.8o-7ubuntu3.2)
Ubuntu 13.10 (Saucy Salamander):released (0.9.8o-7ubuntu3.2.13.10.1)
Ubuntu 14.04 LTS (Trusty Tahr):released (0.9.8o-7ubuntu3.2.14.04.1)
Ubuntu 14.10 (Utopic Unicorn):released (0.9.8o-7ubuntu4)
Package
Upstream:released (0.9.8za,1.0.1h)
Ubuntu 10.04 LTS (Lucid Lynx):released (0.9.8k-7ubuntu8.18)
Ubuntu 12.04 LTS (Precise Pangolin):released (1.0.1-4ubuntu5.14)
Ubuntu 13.10 (Saucy Salamander):released (1.0.1e-3ubuntu1.4)
Ubuntu 14.04 LTS (Trusty Tahr):released (1.0.1f-1ubuntu2.2)
Ubuntu 14.10 (Utopic Unicorn):released (1.0.1f-1ubuntu4)
More Information

Valid XHTML 1.0 Strict

Updated: 2014-07-02 16:14:35 UTC (commit 8198)