CVE-2013-6371

Priority
Medium
Description
The hash functionality in json-c before 0.12 allows context-dependent
attackers to cause a denial of service (CPU consumption) via crafted JSON
data, involving collisions.
References
Bugs
Assigned-to
mdeslaur
Package
Upstream:released (0.11-4)
Ubuntu 10.04 LTS (Lucid Lynx):ignored (reached end-of-life)
Ubuntu 12.04 LTS (Precise Pangolin):released (0.9-1ubuntu1.1)
Ubuntu 13.10 (Saucy Salamander):released (0.11-2ubuntu1.2)
Ubuntu 14.04 LTS (Trusty Tahr):released (0.11-3ubuntu1.2)
Ubuntu 14.10 (Utopic Unicorn):not-affected (0.11-4ubuntu1)
Patches:
Upstream:https://github.com/json-c/json-c/commit/64e36901a0614bf64a19bc3396469c66dcd0b015
More Information

Valid XHTML 1.0 Strict

Updated: 2014-06-12 17:14:36 UTC (commit 8145)