CVE-2013-4549

Priority
Medium
Description
QXmlSimpleReader in Qt before 5.2 allows context-dependent attackers to
cause a denial of service (memory consumption) via an XML Entity Expansion
(XEE) attack.
References
Bugs
Assigned-to
mdeslaur
Package
Upstream:released (5.1.1+dfsg-6)
Ubuntu 10.04 LTS (Lucid Lynx):DNE
Ubuntu 12.04 LTS (Precise Pangolin):DNE
Ubuntu 12.10 (Quantal Quetzal):DNE
Ubuntu 13.10 (Saucy Salamander):released (5.0.2+dfsg1-7ubuntu11.1)
Ubuntu 14.04 LTS (Trusty Tahr):released (5.0.2+dfsg1-7ubuntu13)
Patches:
Upstream:https://codereview.qt-project.org/#change,70708 (head)
Upstream:https://codereview.qt-project.org/#change,71368 (5.1)
Upstream:https://qt.gitorious.org/qt/qtbase/commit/779fa9c590a1bf399b34fbf293d8399e61a1e15c (5.1)
Package
Upstream:needed
Ubuntu 10.04 LTS (Lucid Lynx):ignored (reached end-of-life)
Ubuntu 12.04 LTS (Precise Pangolin):released (4:4.8.1-0ubuntu4.5)
Ubuntu 12.10 (Quantal Quetzal):released (4:4.8.3+dfsg-0ubuntu3.2)
Ubuntu 13.10 (Saucy Salamander):released (4:4.8.4+dfsg-0ubuntu18.1)
Ubuntu 14.04 LTS (Trusty Tahr):released (4:4.8.4+dfsg-0ubuntu20)
Patches:
Upstream:https://codereview.qt-project.org/#change,71010
Upstream:https://qt.gitorious.org/qt/kenji-clone/commit/512a1ce0698d370c313bb561bbf078935fa0342e
Upstream:https://qt.gitorious.org/qt/kenji-clone/commit/cecceb0cdd87482124a73ecf537f3445d68be13e
Package
Upstream:needed
Ubuntu 10.04 LTS (Lucid Lynx):DNE
Ubuntu 12.04 LTS (Precise Pangolin):not-affected (code not present)
Ubuntu 12.10 (Quantal Quetzal):needed
Ubuntu 13.10 (Saucy Salamander):needed
Ubuntu 14.04 LTS (Trusty Tahr):needed
More Information

Valid XHTML 1.0 Strict

Updated: 2014-04-18 13:18:09 UTC (commit 7949)