CVE-2013-1824

Priority
Medium
Description
The SOAP parser in PHP before 5.3.22 and 5.4.x before 5.4.12 allows remote
attackers to read arbitrary files via a SOAP WSDL file containing an XML
external entity declaration in conjunction with an entity reference,
related to an XML External Entity (XXE) issue in the soap_xmlParseFile and
soap_xmlParseMemory functions.
References
Notes
 mdeslaur> this CVE is for an incomplete fix for CVE-2013-1643. Our
 mdeslaur> CVE-2013-1643 did in fact have the complete fix, so we were
 mdeslaur> not affected by this.
Package
Source: php5 (LP Ubuntu Debian)
Upstream:released (5.4.4-14, 5.3.23, 5.4.13)
Ubuntu 12.04 LTS (Precise Pangolin):released (5.3.10-1ubuntu3.6)
More Information

Valid XHTML 1.0 Strict

Updated: 2015-07-29 20:41:30 UTC (commit 9756)