CVE-2012-6152

Priority
Medium
Description
The Yahoo! protocol plugin in libpurple in Pidgin before 2.10.8 does not
properly validate UTF-8 data, which allows remote attackers to cause a
denial of service (application crash) via crafted byte sequences.
References
Assigned-to
mdeslaur
Package
Upstream:released (2.10.8)
Ubuntu 10.04 LTS (Lucid Lynx):ignored (reached end-of-life)
Ubuntu 12.04 LTS (Precise Pangolin):released (1:2.10.3-0ubuntu1.4)
Ubuntu 12.10 (Quantal Quetzal):released (1:2.10.6-0ubuntu2.3)
Ubuntu 13.10 (Saucy Salamander):released (1:2.10.7-0ubuntu4.1.13.10.1)
Ubuntu 14.04 LTS (Trusty Tahr):released (1:2.10.9-0ubuntu1)
Patches:
Upstream:http://hg.pidgin.im/pidgin/main/rev/b0345c25f886
More Information

Valid XHTML 1.0 Strict

Updated: 2014-02-14 14:14:52 UTC (commit 7751)