CVE-2012-2686

Priority
Medium
Description
crypto/evp/e_aes_cbc_hmac_sha1.c in the AES-NI functionality in the TLS 1.1
and 1.2 implementations in OpenSSL 1.0.1 before 1.0.1d allows remote
attackers to cause a denial of service (application crash) via crafted CBC
data.
References
Bugs
Notes
jdstrand> only 1.0.1
mdeslaur> fix included in CVE-2013-0169 patches
mdeslaur> fix reverted in usn-1732-2 because of regression
Assigned-to
mdeslaur
Package
Upstream:released (1.0.1d)
Ubuntu 8.04 LTS (Hardy Heron):not-affected
Ubuntu 10.04 LTS (Lucid Lynx):not-affected
Ubuntu 11.10 (Oneiric Ocelot):not-affected (1.0.0e-2ubuntu4.6)
Ubuntu 12.04 LTS (Precise Pangolin):released (1.0.1-4ubuntu5.8)
Ubuntu 12.10 (Quantal Quetzal):released (1.0.1c-3ubuntu2.3)
Ubuntu 13.04 (Raring Ringtail):released (1.0.1c-4ubuntu8)
More Information

Valid XHTML 1.0 Strict

Updated: 2013-03-25 14:14:34 UTC (commit 6634)