CVE-2012-0027

Priority
Medium
Description
The GOST ENGINE in OpenSSL before 1.0.0f does not properly handle invalid
parameters for the GOST block cipher, which allows remote attackers to
cause a denial of service (daemon crash) via crafted data from a TLS
client.
References
Notes
sbeattie> GOST is not in openssl 0.9.8
Assigned-to
sbeattie
Package
Upstream:released (0.9.8s)
Ubuntu 8.04 LTS (Hardy Heron):DNE
Ubuntu 10.04 LTS (Lucid Lynx):DNE
Ubuntu 11.04 (Natty Narwhal):DNE
Ubuntu 11.10 (Oneiric Ocelot):not-affected (openssl 1.0 only)
Ubuntu 12.04 LTS (Precise Pangolin):not-affected (openssl 1.0 only)
Package
Upstream:released (0.9.8s,1.0.0f)
Ubuntu 8.04 LTS (Hardy Heron):not-affected (openssl 1.0 only)
Ubuntu 10.04 LTS (Lucid Lynx):not-affected (openssl 1.0 only)
Ubuntu 11.04 (Natty Narwhal):not-affected (openssl 1.0 only)
Ubuntu 11.10 (Oneiric Ocelot):released (1.0.0e-2ubuntu4.2)
Ubuntu 12.04 LTS (Precise Pangolin):not-affected (1.0.0g-1ubuntu1)
Patches:
Upstream:http://cvs.openssl.org/chngview?cn=21925
More Information

Valid XHTML 1.0 Strict

Updated: 2012-06-01 15:22:35 UTC (commit 5347)