CVE-2011-4577

Priority
Medium
Description
OpenSSL before 0.9.8s and 1.x before 1.0.0f, when RFC 3779 support is
enabled, allows remote attackers to cause a denial of service (assertion
failure) via an X.509 certificate containing certificate-extension data
associated with (1) IP address blocks or (2) Autonomous System (AS)
identifiers.
References
Assigned-to
sbeattie
Package
Upstream:released (0.9.8s)
Ubuntu 8.04 LTS (Hardy Heron):DNE
Ubuntu 10.04 LTS (Lucid Lynx):DNE
Ubuntu 11.04 (Natty Narwhal):DNE
Ubuntu 11.10 (Oneiric Ocelot):released (0.9.8o-7ubuntu1.2)
Ubuntu 12.04 LTS (Precise Pangolin):released (0.9.8o-7ubuntu3.1)
Patches:
Upstream:http://cvs.openssl.org/chngview?cn=21924
Package
Upstream:released (0.9.8s,1.0.0f)
Ubuntu 8.04 LTS (Hardy Heron):released (0.9.8g-4ubuntu3.15)
Ubuntu 10.04 LTS (Lucid Lynx):released (0.9.8k-7ubuntu8.8)
Ubuntu 11.04 (Natty Narwhal):released (0.9.8o-5ubuntu1.2)
Ubuntu 11.10 (Oneiric Ocelot):released (1.0.0e-2ubuntu4.2)
Ubuntu 12.04 LTS (Precise Pangolin):not-affected (1.0.0g-1ubuntu1)
Patches:
Upstream:http://cvs.openssl.org/chngview?cn=21937
More Information

Valid XHTML 1.0 Strict

Updated: 2012-06-01 15:22:34 UTC (commit 5347)