CVE-2011-4364

Priority
Medium
Description
Buffer overflow in the Sierra VMD decoder in libavcodec in FFmpeg 0.5.x
before 0.5.7, 0.6.x before 0.6.4, 0.7.x before 0.7.9 and 0.8.x before
0.8.8; and in Libav 0.5.x before 0.5.6, 0.6.x before 0.6.4, and 0.7.x
before 0.7.3 allows remote attackers to cause a denial of service (crash)
and possibly execute arbitrary code via a crafted VMD file, related to
corrupted streams.
References
Notes
mdeslaur> ffmpeg-extra in multiverse needs to have matching version
mdeslaur> libav-extra is built with tarball produced by libav package
Package
Source: libav (LP Ubuntu Debian)
Upstream:released (0.7.3)
Ubuntu 8.04 LTS (Hardy Heron):DNE
Ubuntu 10.04 LTS (Lucid Lynx):DNE
Ubuntu 11.04 (Natty Narwhal):released (4:0.6.4-0ubuntu0.11.04.1)
Ubuntu 11.10 (Oneiric Ocelot):released (4:0.7.3-0ubuntu0.11.10.1)
Ubuntu 12.04 LTS (Precise Pangolin):not-affected (4:0.7.3-2ubuntu1)
Patches:
Upstream:http://git.libav.org/?p=libav.git;a=commit;h=c0cbe36b18ab3eb13a53fe684ec1f63a00df2c86
Package
Upstream:needs-triage
Ubuntu 8.04 LTS (Hardy Heron):DNE
Ubuntu 10.04 LTS (Lucid Lynx):released (4:0.5.1-1ubuntu1.3)
Ubuntu 11.04 (Natty Narwhal):DNE
Ubuntu 11.10 (Oneiric Ocelot):DNE
Ubuntu 12.04 LTS (Precise Pangolin):DNE
Package
Upstream:needs-triage
Ubuntu 8.04 LTS (Hardy Heron):ignored (reached end-of-life)
Ubuntu 10.04 LTS (Lucid Lynx):released (4:0.5.1-1ubuntu1.3)
Ubuntu 11.04 (Natty Narwhal):DNE
Ubuntu 11.10 (Oneiric Ocelot):DNE
Ubuntu 12.04 LTS (Precise Pangolin):DNE
Patches:
Upstream:http://git.videolan.org/?p=ffmpeg.git;a=commit;h=c0cbe36b18ab3eb13a53fe684ec1f63a00df2c86
Package
Upstream:needs-triage
Ubuntu 8.04 LTS (Hardy Heron):DNE
Ubuntu 10.04 LTS (Lucid Lynx):DNE
Ubuntu 11.04 (Natty Narwhal):released (4:0.6.4-1ubuntu1)
Ubuntu 11.10 (Oneiric Ocelot):released (4:0.7.3ubuntu0.11.10.1)
Ubuntu 12.04 LTS (Precise Pangolin):not-affected (4:0.7.3ubuntu1)
More Information

Valid XHTML 1.0 Strict

Updated: 2012-08-22 22:14:30 UTC (commit 5659)