CVE-2011-3940

Priority
Medium
Description
nsvdec.c in libavcodec in FFmpeg 0.7.x before 0.7.12 and 0.8.x before
0.8.11, and in Libav 0.5.x before 0.5.9, 0.6.x before 0.6.6, 0.7.x before
0.7.5, and 0.8.x before 0.8.1, allows remote attackers to cause a denial of
service (out-of-bounds read and write) via a crafted NSV file that triggers
"use of uninitialized streams."
References
Notes
 mdeslaur> ffmpeg-extra in multiverse needs to have matching version
 mdeslaur> libav-extra is built with tarball produced by libav package
Package
Source: libav (LP Ubuntu Debian)
Upstream:released (0.6.6,0.7.5,0.8.1)
Ubuntu 12.04 LTS (Precise Pangolin):not-affected (4:0.8.1-0ubuntu1)
Package
Upstream:needs-triage
Ubuntu 12.04 LTS (Precise Pangolin):DNE
Package
Upstream:released (0.5.9)
Ubuntu 12.04 LTS (Precise Pangolin):DNE
Patches:
Upstream:http://git.videolan.org/?p=ffmpeg.git;a=commit;h=5c011706bc752d34bc6ada31d7df2ca0c9af7c6b
Upstream:http://git.videolan.org/?p=ffmpeg.git;a=commit;h=8fd8a48263ff1437f9d02d7e78dc63efb9b5ed3a
Upstream:http://git.videolan.org/?p=ffmpeg.git;a=commit;h=c898431ca5ef2a997fe9388b650f658fb60783e5
Package
Upstream:needs-triage
Ubuntu 12.04 LTS (Precise Pangolin):not-affected (4:0.8.1ubuntu1)
More Information

Valid XHTML 1.0 Strict

Updated: 2015-07-29 20:40:08 UTC (commit 9756)