CVE-2011-3170

Priority
Medium
Description
The gif_read_lzw function in filter/image-gif.c in CUPS 1.4.8 and earlier
does not properly handle the first code word in an LZW stream, which allows
remote attackers to trigger a heap-based buffer overflow, and possibly
execute arbitrary code, via a crafted stream, a different vulnerability
than CVE-2011-2896.
References
Bugs
Notes
 mdeslaur> This also affects cups 1.5.x and isn't fixed in 1.5.0
 mdeslaur> gimp was fixed correctly with a single commit, so doesn't have
 mdeslaur> this issue, which is an incomplete fix.
Assigned-to
mdeslaur
Package
Upstream:needs-triage
Ubuntu 12.04 LTS (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 15.04 (Vivid Vervet):DNE
Ubuntu 15.10 (Wily Werewolf):DNE
Package
Source: cups (LP Ubuntu Debian)
Upstream:released (1.5.0-8)
Ubuntu 12.04 LTS (Precise Pangolin):not-affected (1.5.0-8)
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (1.5.0-8)
Ubuntu 15.04 (Vivid Vervet):not-affected (1.5.0-8)
Ubuntu 15.10 (Wily Werewolf):not-affected (1.5.0-8)
Patches:
Upstream:http://cups.org/str.php?L3914
Upstream:r9865
Package
Upstream:needs-triage
Ubuntu 12.04 LTS (Precise Pangolin):needed
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 15.04 (Vivid Vervet):needed
Ubuntu 15.10 (Wily Werewolf):needed
Patches:
Upstream:http://www.swi-prolog.org/git/packages/xpce.git/commit/30fbc4e030cbef5871e1b96c31458116ce3e2ee8
Package
Source: gimp (LP Ubuntu Debian)
Upstream:not-affected
Ubuntu 12.04 LTS (Precise Pangolin):not-affected
Ubuntu 14.04 LTS (Trusty Tahr):not-affected
Ubuntu 15.04 (Vivid Vervet):not-affected
Ubuntu 15.10 (Wily Werewolf):not-affected
More Information

Valid XHTML 1.0 Strict

Updated: 2015-07-29 20:16:36 UTC (commit 9756)