CVE-2010-3704

Priority
Medium
Description
The FoFiType1::parse function in fofi/FoFiType1.cc in the PDF parser in
xpdf before 3.02pl5, poppler 0.8.7 and possibly other versions up to
0.15.1, kdegraphics, and possibly other products allows context-dependent
attackers to cause a denial of service (crash) and possibly execute
arbitrary code via a PDF file with a crafted PostScript Type1 font that
contains a negative array index, which bypasses input validation and
triggers memory corruption.
References
Bugs
Assigned-to
mdeslaur
Package
Source: gpdf (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 10.04 LTS (Lucid Lynx):DNE
Ubuntu 12.04 LTS (Precise Pangolin):DNE
Ubuntu 13.10 (Saucy Salamander):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 14.10 (Utopic Unicorn):DNE
Package
Upstream:needs-triage
Ubuntu 10.04 LTS (Lucid Lynx):DNE
Ubuntu 12.04 LTS (Precise Pangolin):DNE
Ubuntu 13.10 (Saucy Salamander):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 14.10 (Utopic Unicorn):DNE
Package
Source: xpdf (LP Ubuntu Debian)
Upstream:released (3.02-12)
Ubuntu 10.04 LTS (Lucid Lynx):released (3.02-2ubuntu1.1)
Ubuntu 12.04 LTS (Precise Pangolin):not-affected (3.02-12ubuntu1)
Ubuntu 13.10 (Saucy Salamander):not-affected (3.02-12ubuntu1)
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (3.02-12ubuntu1)
Ubuntu 14.10 (Utopic Unicorn):not-affected (3.02-12ubuntu1)
Patches:
Debdiff:https://bugs.launchpad.net/ubuntu/+source/xpdf/+bug/701220
Package
Upstream:needs-triage
Ubuntu 10.04 LTS (Lucid Lynx):ignored (reached end-of-life)
Ubuntu 12.04 LTS (Precise Pangolin):needs-triage
Ubuntu 13.10 (Saucy Salamander):ignored (reached end-of-life)
Ubuntu 14.04 LTS (Trusty Tahr):needs-triage
Ubuntu 14.10 (Utopic Unicorn):needs-triage
Package
Upstream:needs-triage
Ubuntu 10.04 LTS (Lucid Lynx):not-affected (code not present)
Ubuntu 12.04 LTS (Precise Pangolin):DNE
Ubuntu 13.10 (Saucy Salamander):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 14.10 (Utopic Unicorn):DNE
Package
Source: ipe (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 10.04 LTS (Lucid Lynx):ignored (reached end-of-life)
Ubuntu 12.04 LTS (Precise Pangolin):needs-triage
Ubuntu 13.10 (Saucy Salamander):ignored (reached end-of-life)
Ubuntu 14.04 LTS (Trusty Tahr):needs-triage
Ubuntu 14.10 (Utopic Unicorn):needs-triage
Package
Upstream:needs-triage
Ubuntu 10.04 LTS (Lucid Lynx):not-affected (linked to poppler)
Ubuntu 12.04 LTS (Precise Pangolin):not-affected (linked to poppler)
Ubuntu 13.10 (Saucy Salamander):not-affected (linked to poppler)
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (linked to poppler)
Ubuntu 14.10 (Utopic Unicorn):not-affected (linked to poppler)
Package
Upstream:released (0.14.4)
Ubuntu 10.04 LTS (Lucid Lynx):released (0.12.4-0ubuntu5.1)
Ubuntu 12.04 LTS (Precise Pangolin):not-affected (0.16.0-0ubuntu2)
Ubuntu 13.10 (Saucy Salamander):not-affected (0.16.0-0ubuntu2)
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (0.16.0-0ubuntu2)
Ubuntu 14.10 (Utopic Unicorn):not-affected (0.16.0-0ubuntu2)
Patches:
Upstream:http://cgit.freedesktop.org/poppler/poppler/commit/?id=39d140bfc0b8239bdd96d6a55842034ae5c05473
Package
Upstream:needs-triage
Ubuntu 10.04 LTS (Lucid Lynx):not-affected (linked to poppler)
Ubuntu 12.04 LTS (Precise Pangolin):DNE
Ubuntu 13.10 (Saucy Salamander):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 14.10 (Utopic Unicorn):DNE
Package
Upstream:needs-triage
Ubuntu 10.04 LTS (Lucid Lynx):DNE
Ubuntu 12.04 LTS (Precise Pangolin):DNE
Ubuntu 13.10 (Saucy Salamander):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 14.10 (Utopic Unicorn):DNE
Package
Upstream:needs-triage
Ubuntu 10.04 LTS (Lucid Lynx):DNE
Ubuntu 12.04 LTS (Precise Pangolin):DNE
Ubuntu 13.10 (Saucy Salamander):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 14.10 (Utopic Unicorn):DNE
More Information

Valid XHTML 1.0 Strict

Updated: 2014-07-17 15:14:37 UTC (commit 8246)