CVE-2010-3567

Priority
Low
Description
Unspecified vulnerability in the 2D component in Oracle Java SE and Java
for Business 6 Update 21, and 5.0 Update 25 allows remote attackers to
affect confidentiality, integrity, and availability via unknown vectors.
NOTE: the previous information was obtained from the October 2010 CPU.
Oracle has not commented on claims from a reliable downstream vendor that
this is related to a calculation error in right-to-left text character
counts for the ICU OpenType font rendering implementation, which triggers
an out-of-bounds memory access.
Ubuntu-Description
It was discovered that a miscalculation in the OpenType font
rendering implementation would allow out-of-bounds memory access. This
could allow an attacker to execute arbitrary code with the privileges
of the user running a java application.
References
Notes
sbeattie> red hat description: Miscalculation in the OpenType font
rendering implementation caused out-of-bounds memory access, which
could allow remote attackers to execute code with the privileges
of the user running the java process.
Package
Upstream:needs-triage
Ubuntu 8.04 LTS (Hardy Heron):released (1.8.2-4ubuntu1~8.04.1)
Ubuntu 10.04 LTS (Lucid Lynx):released (1.8.2-4ubuntu2)
Ubuntu 11.04 (Natty Narwhal):not-affected (6b20-1.10~pre2-0ubuntu5)
Package
Upstream:needs-triage
Ubuntu 8.04 LTS (Hardy Heron):released (6.22-0ubuntu1~8.04.1)
Ubuntu 10.04 LTS (Lucid Lynx):released (6.22-0ubuntu1~10.04)
Ubuntu 11.04 (Natty Narwhal):DNE
Package
Upstream:released (6b22)
Ubuntu 8.04 LTS (Hardy Heron):DNE
Ubuntu 10.04 LTS (Lucid Lynx):not-affected (6b18-1.8.3-0ubuntu1~10.04.1)
Ubuntu 11.04 (Natty Narwhal):not-affected (6b18-1.8.3-1ubuntu3)
More Information

Valid XHTML 1.0 Strict

Updated: 2012-06-01 15:21:23 UTC (commit 5347)