CVE-2010-3056

Priority
Medium
Description
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 2.11.x
before 2.11.10.1 and 3.x before 3.3.5.1 allow remote attackers to inject
arbitrary web script or HTML via vectors related to (1) db_search.php, (2)
db_sql.php, (3) db_structure.php, (4) js/messages.php, (5)
libraries/common.lib.php, (6) libraries/database_interface.lib.php, (7)
libraries/dbi/mysql.dbi.lib.php, (8) libraries/dbi/mysqli.dbi.lib.php, (9)
libraries/db_info.inc.php, (10) libraries/sanitizing.lib.php, (11)
libraries/sqlparser.lib.php, (12) server_databases.php, (13)
server_privileges.php, (14) setup/config.php, (15) sql.php, (16)
tbl_replace.php, and (17) tbl_sql.php.
References
Package
Upstream:released (3.3.5.1)
Ubuntu 10.04 LTS (Lucid Lynx):ignored (reached end-of-life)
Ubuntu 12.04 LTS (Precise Pangolin):not-affected (4:3.3.6-1)
Ubuntu 12.10 (Quantal Quetzal):not-affected (4:3.3.6-1)
Ubuntu 13.04 (Raring Ringtail):not-affected (4:3.3.6-1)
Ubuntu 13.10 (Saucy Salamander):not-affected (4:3.3.6-1)
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (4:3.3.6-1)
More Information

Valid XHTML 1.0 Strict

Updated: 2013-12-20 21:16:14 UTC (commit 7585)