CVE-2010-2541

Priority
Medium
Description
Buffer overflow in ftmulti.c in the ftmulti demo program in FreeType before
2.4.2 allows remote attackers to cause a denial of service (application
crash) or possibly execute arbitrary code via a crafted font file.
References
Bugs
Assigned-to
mdeslaur
Package
Upstream:released (2.4.2)
Ubuntu 8.04 LTS (Hardy Heron):released (2.3.5-1ubuntu4.8.04.4)
Ubuntu 10.04 LTS (Lucid Lynx):released (2.3.11-1ubuntu2.2)
Patches:
Upstream:http://git.savannah.gnu.org/cgit/freetype/freetype2-demos.git/commit/?id=3636982a7666bcfa0e47fb31d565314d1b3e7d78
Upstream:http://git.savannah.gnu.org/cgit/freetype/freetype2-demos.git/commit/?id=b4d857b39fb4fcc20b5fa5cf03fde61a4919eb46
Upstream:http://git.savannah.gnu.org/cgit/freetype/freetype2-demos.git/commit/?id=8dceb1f3f5a821ad1e8d6d53c323f4336e619ff4
More Information

Valid XHTML 1.0 Strict

Updated: 2012-06-01 15:21:10 UTC (commit 5347)